API version: unstable
API version: 2021-01 Release candidate
API version: 2020-10 Latest
API version: 2020-07
API version: 2020-04
API version: 2020-01
API version: 2019-10 Unsupported
API version: 2019-07 Unsupported

paymentsAppConfigure mutation

Version unstable

Configure the partner managed gateway onto the merchant's store.

Required access

write_payment_gateways access scope.

Interactive example

This is an example mutation query. Use the embedded interactive tool below to edit the query.

Hint: use Ctrl + Space for autocompleting fields.


Arguments

externalHandle ( String )

Handle used in the external system.

ready ( Boolean! ) required

The provider is ready to process merchant's payments.

Return fields

paymentsAppConfiguration (PaymentsAppConfiguration)

The production configuration of the payments app.

userErrors ([UserError!]!)

List of errors that occurred executing the mutation.

Version 2021-01 (Release candidate)

Configure the partner managed gateway onto the merchant's store.

Required access

write_payment_gateways access scope.

Interactive example

This is an example mutation query. Use the embedded interactive tool below to edit the query.

Hint: use Ctrl + Space for autocompleting fields.


Arguments

externalHandle ( String )

Handle used in the external system.

ready ( Boolean! ) required

The provider is ready to process merchant's payments.

Return fields

paymentsAppConfiguration (PaymentsAppConfiguration)

The production configuration of the payments app.

userErrors ([UserError!]!)

List of errors that occurred executing the mutation.